Mungkin banyak yang bertanya, untuk apa sih downgrade Firefox? Bukankan yang lebih baru lebih bagus?

Ada beberapa alasan kenapa harus downgrade atau menurunkan versi Mozilla Firefox. Misalnya ketika saya ingin login ke VMware vCloud Director dan ke sebuah aplikasi yang dibuat teman saya.

Saat mencoba membuka kedua halaman tersebut, muncul error yang sama yaitu “Secure Connection Failed”

Diffie-Hellman

Untuk mengatasi masalah itu harus diubah pada aplikasinya atau gunakan saja Firefox versi jadul. Setelah berdiskusi dengan teman saya, disarankan memakai Firefox versi 28.

Pada petunjuk berikut akan dijelaskan cara downgrade Firefox ke versi 28. Percobaan dilakukan pada Ubuntu 14.04 dan Linuxmint 17.

Untuk sistem operasi lain silakan unduh langsung di sini.

Mengecek Repositori

Hal yang pertama dilakukan adalah melihat apakah versi Firefox yang diinginkan ada di repositori Ubuntu. Untuk itu jalankan perintah berikut:

$ sudo apt-cache show firefox | grep Version
Version: 44.0+linuxmint1+rosa
Version: 44.0+build3-0ubuntu0.14.04.1
Version: 28.0+build2-0ubuntu2

Seperti yang terlihat di atas, pada repositori terdapat Firefox versi 28.

Menginstall Firefox

Jalankan:

$ sudo apt-get install firefox=28.0+build2-0ubuntu2

Untuk menahan sistem agar tidak mengupgrade Firefox ke versi yang baru, jalankan perintah:

$ sudo aptitude hold firefox

Untuk membukanya kembali:

$ sudo aptitude unhold firefox